PyPI/django CVE-2025-32873: medium 5.3, EPSS 14.31%
Django has a denial-of-service possibility in strip_tags()
Action: Upgrade django to 4.2.21 or later.
pip install django==4.2.21pip install django==5.1.9pip install django==5.2.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.2 | 4.2.21 | - |
| 5.1 | 5.1.9 | - |
| 5.2 | 5.2.1 | - |
Fixed versions
| 4.2.21 | 5.1.9 | 5.2.1 |
Sources
- osv: GHSA-8j24-cjrq-gr2m
- https://nvd.nist.gov/vuln/detail/CVE-2025-32873
- https://github.com/django/django/commit/9f3419b519799d69f2aba70b9d25abe2e70d03e0
- https://docs.djangoproject.com/en/dev/releases/security
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2025-37.yaml
- https://groups.google.com/g/django-announce
- https://www.djangoproject.com/weblog/2025/may/07/security-releases
- http://www.openwall.com/lists/oss-security/2025/05/07/1
CVE-2025-32873 · published · modified · JSON