PyPI/tensorflow-gpu CVE-2022-23587: high 8.8, EPSS 0.90%
Integer overflow in TensorFlow
Action: Upgrade tensorflow-gpu to 2.5.3 or later.
pip install tensorflow-gpu==2.5.3pip install tensorflow-gpu==2.6.3pip install tensorflow-gpu==2.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.3 | - |
| 2.6.0 | 2.6.3 | - |
| 2.7.0 | 2.7.1 | - |
Fixed versions
| 2.5.3 | 2.6.3 | 2.7.1 |
Sources
- osv: GHSA-8jj7-5vxc-pg2q#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-8jj7-5vxc-pg2q
- https://nvd.nist.gov/vuln/detail/CVE-2022-23587
- https://github.com/tensorflow/tensorflow/commit/0aaaae6eca5a7175a193696383f582f53adab23f
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-96.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-151.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/a1320ec1eac186da1d03f033109191f715b2b130/tensorflow/core/grappler/costs/op_level_cost_estimator.cc#L2621-L2689
CVE-2022-23587 · published · modified · JSON