PyPI/notebook CVE-2015-7337: critical 9.8, EPSS 2.49%
Improper Input Validation in Jupyter Notebook
Action: Upgrade notebook to 4.0.5 or later.
pip install notebook==4.0.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.0.0 | 4.0.5 | - |
Fixed versions
| 4.0.5 |
Sources
- osv: GHSA-92mr-v722-f48m
- https://nvd.nist.gov/vuln/detail/CVE-2015-7337
- https://github.com/ipython/ipython/commit/0a8096adf165e2465550bd5893d7e352544e5967
- https://github.com/jupyter/notebook/commit/9e63dd89b603dfbe3a7e774d8a962ee0fa30c0b5
- https://bugzilla.redhat.com/show_bug.cgi?id=1264067
- https://github.com/advisories/GHSA-92mr-v722-f48m
- https://github.com/pypa/advisory-database/tree/main/vulns/ipython/PYSEC-2015-25.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/notebook/PYSEC-2015-27.yaml
- https://security.gentoo.org/glsa/201512-02
- http://lists.fedoraproject.org/pipermail/package-announce/2015-September/167670.html
- http://seclists.org/oss-sec/2015/q3/558
- http://seclists.org/oss-sec/2015/q3/634
CVE-2015-7337 · published · modified · JSON