PyPI/picklescan CVE-2025-46417: high 7.5, EPSS 0.23%
Picklescan Vulnerable to Exfiltration via DNS via linecache and ssl.get_server_certificate
Action: Upgrade picklescan to 0.0.25 or later.
pip install picklescan==0.0.25Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.25 | - |
Fixed versions
| 0.0.25 |
Sources
- osv: GHSA-93mv-x874-956g
- nvd: CVE-2025-46417
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-93mv-x874-956g
- https://github.com/mmaitre314/picklescan/pull/40
- https://github.com/mmaitre314/picklescan
- https://github.com/pypa/advisory-database/tree/main/vulns/picklescan/PYSEC-2025-34.yaml
CVE-2025-46417 · published · modified · JSON