PyPI/virtualenv CVE-2026-102930: high 7.7, EPSS 0.20%
virtualenv: Downloaded seed wheels (pip/setuptools) are not integrity-checked before use
Action: Upgrade virtualenv to 21.7.12 or later.
pip install virtualenv==21.7.12Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 21.7.12 | - |
Fixed versions
| 21.7.12 |
Sources
- osv: GHSA-94p9-xgh2-xp45
- nvd: CVE-2026-102930
- https://github.com/pypa/virtualenv/security/advisories/GHSA-94p9-xgh2-xp45
- https://github.com/pypa/virtualenv/pull/3251
- https://github.com/pypa/virtualenv/commit/a01ed3e2f239d6ab1fce62c5c7664ccf268fff6d
- https://github.com/pypa/advisory-database/tree/main/vulns/virtualenv/PYSEC-2026-4011.yaml
- https://github.com/pypa/virtualenv
- https://github.com/pypa/virtualenv/releases/tag/21.7.12
- https://pypi.org/project/virtualenv
CVE-2026-102930 · published · modified · JSON