PyPI/apache-airflow CVE-2026-41017: medium 5.9, EPSS 0.35%
Apache Airflow has a Sensitive Cookie in HTTPS Session Without 'Secure' Attribute
Action: Upgrade apache-airflow to 3.2.2 or later.
pip install apache-airflow==3.2.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.0.0 | 3.2.2 | - |
Fixed versions
| 3.2.2 |
Sources
- osv: GHSA-95v7-h9j5-gvjr
- https://nvd.nist.gov/vuln/detail/CVE-2026-41017
- https://github.com/apache/airflow/pull/65348
- https://github.com/apache/airflow
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2026-171.yaml
- https://lists.apache.org/thread/9jx0sk49c1250zflx0q3clc717qgjdch
- http://www.openwall.com/lists/oss-security/2026/05/31/6
CVE-2026-41017 · published · modified · JSON