PyPI/tensorflow CVE-2020-5215: medium 5, EPSS 0.59%
Segmentation faultin TensorFlow when converting a Python string to `tf.float16`
Action: Upgrade tensorflow to 1.15.2 or later.
pip install tensorflow==1.15.2pip install tensorflow==2.0.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.2 | - |
| 2.0.0 | 2.0.1 | - |
Fixed versions
| 1.15.2 | 2.0.1 |
Sources
- osv: GHSA-977j-xj7q-2jr9
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-977j-xj7q-2jr9
- https://nvd.nist.gov/vuln/detail/CVE-2020-5215
- https://github.com/tensorflow/tensorflow/commit/5ac1b9e24ff6afc465756edf845d2e9660bd34bf
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-303.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-338.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-258.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/releases/tag/v1.15.2
- https://github.com/tensorflow/tensorflow/releases/tag/v2.0.1
CVE-2020-5215 · published · modified · JSON