PyPI/python-libnmap CVE-2019-1010017: high 7.5, EPSS 1.52%
XML Injection in python-libnmap
Action: Upgrade python-libnmap to 0.7.2 or later.
pip install python-libnmap==0.7.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.7.2 | - |
Fixed versions
| 0.7.2 |
Sources
- osv: GHSA-9ccv-p7fg-m73x
- https://nvd.nist.gov/vuln/detail/CVE-2019-1010017
- https://github.com/savon-noir/python-libnmap/issues/87
- https://github.com/savon-noir/python-libnmap/commit/71b707758851e4b622f87d9a73266e06f60aeab4
- https://github.com/pypa/advisory-database/tree/main/vulns/python-libnmap/PYSEC-2019-218.yaml
- https://github.com/savon-noir/python-libnmap
CVE-2019-1010017 · published · modified · JSON