PyPI/pypdf CVE-2026-28804: medium 5.3, EPSS 0.44%
pypdf vulnerable to inefficient decoding of ASCIIHexDecode streams
Action: Upgrade pypdf to 6.7.5 or later.
pip install pypdf==6.7.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.7.5 | - |
Fixed versions
| 6.7.5 |
Sources
- osv: GHSA-9m86-7pmv-2852
- nvd: CVE-2026-28804
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-9m86-7pmv-2852
- https://github.com/py-pdf/pypdf/pull/3666
- https://github.com/py-pdf/pypdf/commit/648c627d2657447dfb1773412af05a0a5103b98f
- https://github.com/py-pdf/pypdf
- https://github.com/py-pdf/pypdf/releases/tag/6.7.5
CVE-2026-28804 · published · modified · JSON