PyPI/jupyterlab CVE-2024-43805: high 7.6, EPSS 0.40%
HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering
Action: Upgrade jupyterlab to 3.6.8 or later.
pip install jupyterlab==3.6.8pip install jupyterlab==4.2.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.6.8 | - |
| 4.0.0 | 4.2.5 | - |
Fixed versions
| 3.6.8 | 4.2.5 |
Sources
- osv: GHSA-9q39-rmj3-p4r2
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-9q39-rmj3-p4r2
- https://nvd.nist.gov/vuln/detail/CVE-2024-43805
- https://github.com/jupyterlab/jupyterlab/commit/06ad9de836f155add7d3d651ef936cc4c5ea8093
- https://github.com/jupyterlab/jupyterlab/commit/88e24baac551196f9cb3de16bd060a7ab1597674
- https://github.com/jupyterlab/jupyterlab
CVE-2024-43805 · published · modified · JSON