PyPI/mercurial CVE-2016-3630: high 8.8, EPSS 4.87%
Mercurial arbitrary code execution vulnerability
Action: Upgrade mercurial to 3.7.3 or later.
pip install mercurial==3.7.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.7.3 | - |
Fixed versions
| 3.7.3 |
Sources
- osv: GHSA-9vjf-jjcq-3gh7
- https://nvd.nist.gov/vuln/detail/CVE-2016-3630
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2016-29.yaml
- https://security.gentoo.org/glsa/201612-19
- https://selenic.com/repo/hg-stable/rev/b6ed2505d6cf
- https://selenic.com/repo/hg-stable/rev/b9714d958e89
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.7.3_.282016-3-29.29
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181505.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181542.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00018.html
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00043.html
- http://www.debian.org/security/2016/dsa-3542
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
CVE-2016-3630 · published · modified · JSON