PyPI/pyftpdlib CVE-2007-6737: high 7.3, EPSS 2.11%
Improper Authentication in pyftpdlib
Action: Upgrade pyftpdlib to 0.2.0 or later.
pip install pyftpdlib==0.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.2.0 | - |
Fixed versions
| 0.2.0 |
Sources
- osv: GHSA-9x66-ghqx-8g5r
- https://nvd.nist.gov/vuln/detail/CVE-2007-6737
- https://github.com/giampaolo/pyftpdlib/issues/20
- https://github.com/advisories/GHSA-9x66-ghqx-8g5r
- https://github.com/giampaolo/pyftpdlib
- https://github.com/pypa/advisory-database/tree/main/vulns/pyftpdlib/PYSEC-2010-21.yaml
- http://code.google.com/p/pyftpdlib/issues/detail?id=20
- http://code.google.com/p/pyftpdlib/source/browse/trunk/HISTORY
- http://code.google.com/p/pyftpdlib/source/detail?r=23
- http://code.google.com/p/pyftpdlib/source/diff?spec=svn23&r=23&format=side&path=/trunk/pyftpdlib/FTPServer.py
CVE-2007-6737 · published · modified · JSON