PyPI/django CVE-2009-2659: high 7.5, EPSS 2.28%
Django Admin Media Handler Vulnerable to Directory Traversal
Action: Upgrade django to 0.96.4 or later.
pip install django==0.96.4pip install django==1.0.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.96.0 | 0.96.4 | - |
| 1.0 | 1.0.3 | - |
Fixed versions
| 0.96.4 | 1.0.3 |
Sources
- osv: GHSA-9xg7-gg9m-rmq9
- https://nvd.nist.gov/vuln/detail/CVE-2009-2659
- https://github.com/django/django/commit/da85d76fd6ca846f3b0ff414e042ddb5e62e2e69
- https://github.com/django/django/commit/df7f917b7f51ba969faa49d000ffc79572c5dcb4
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2009-3.yaml
- https://web.archive.org/web/20111211001428/http://www.securityfocus.com/bid/35859
- https://www.redhat.com/archives/fedora-package-announce/2009-August/msg00055.html
- https://www.redhat.com/archives/fedora-package-announce/2009-August/msg00069.html
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=539134
- http://code.djangoproject.com/changeset/11353
- http://www.djangoproject.com/weblog/2009/jul/28/security
- http://www.openwall.com/lists/oss-security/2009/07/29/2
CVE-2009-2659 · published · modified · JSON