PyPI/vyper CVE-2023-42443: high 8.1, EPSS 0.83%
Vyper vulnerable to memory corruption in certain builtins utilizing `msize`
Action: Upgrade vyper to 0.3.10 or later.
pip install vyper==0.3.10Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.3.4 | 0.3.10 | - |
Fixed versions
| 0.3.10 |
Sources
- osv: GHSA-c647-pxm2-c52w
- https://github.com/vyperlang/vyper/security/advisories/GHSA-c647-pxm2-c52w
- https://nvd.nist.gov/vuln/detail/CVE-2023-42443
- https://github.com/vyperlang/vyper/issues/3609
- https://github.com/vyperlang/vyper/pull/3610
- https://github.com/vyperlang/vyper/commit/79303fc4fcba06994ee5c6a7baef57bdb185006c
- https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2023-306.yaml
- https://github.com/vyperlang/vyper
CVE-2023-42443 · published · modified · JSON