PyPI/botframework-connector CVE-2021-1725: medium 5.3, EPSS 1.07%
botframework-connector vulnerable to Improper Authentication
Action: Upgrade botframework-connector to 4.7.2 or later.
pip install botframework-connector==4.7.2pip install botframework-connector==4.8.1pip install botframework-connector==4.9.3pip install botframework-connector==4.10.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.7.0 | 4.7.2 | - |
| 4.8.0 | 4.8.1 | - |
| 4.9.0 | 4.9.3 | - |
| 4.10.0 | 4.10.1 | - |
Fixed versions
| 4.7.2 | 4.8.1 | 4.9.3 | 4.10.1 |
Sources
- osv: GHSA-cqff-fx2x-p86v
- https://github.com/microsoft/botbuilder-python/security/advisories/GHSA-cqff-fx2x-p86v
- https://github.com/microsoft/botbuilder-python/blob/main/doc/SkillClaimsValidation.md
- https://github.com/pypa/advisory-database/tree/main/vulns/botframework-connector/PYSEC-2021-422.yaml
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2021-1725
- https://pypi.org/project/botframework-connector
CVE-2021-1725 · published · modified · JSON