tocsin

PyPI/cairosvg CVE-2026-31899: high 7.5, EPSS 0.51%

CairoSVG vulnerable to Exponential DoS via recursive <use> element amplification

Action: Upgrade cairosvg to 2.9.0 or later.

pip install cairosvg==2.9.0

Affected

introducedfixedlast affected
02.9.0-

Fixed versions

2.9.0

Sources

CVE-2026-31899 · published · modified · JSON