PyPI/tensorflow-cpu CVE-2022-35964: medium 5.9, EPSS 0.49%
TensorFlow vulnerable to segfault in `BlockLSTMGradV2`
Action: Upgrade tensorflow-cpu to 2.7.2 or later.
pip install tensorflow-cpu==2.7.2pip install tensorflow-cpu==2.8.1pip install tensorflow-cpu==2.9.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.2 | - |
| 2.8.0 | 2.8.1 | - |
| 2.9.0 | 2.9.1 | - |
Fixed versions
| 2.7.2 | 2.8.1 | 2.9.1 |
Sources
- osv: GHSA-f7r5-q7cx-h668#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f7r5-q7cx-h668
- https://nvd.nist.gov/vuln/detail/CVE-2022-35964
- https://github.com/tensorflow/tensorflow/commit/2a458fc4866505be27c62f81474ecb2b870498fa
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0
CVE-2022-35964 · published · modified · JSON