PyPI/codechecker CVE-2024-53829: high 8.2, EPSS 0.25%
Cross-Site Request Forgery in CodeChecker API
Action: Upgrade codechecker to 6.24.5 or later.
pip install codechecker==6.24.5Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.24.5 | - |
Fixed versions
| 6.24.5 |
Sources
- osv: GHSA-f8c8-4pm7-w885
- https://github.com/Ericsson/codechecker/security/advisories/GHSA-f8c8-4pm7-w885
- https://nvd.nist.gov/vuln/detail/CVE-2024-53829
- https://github.com/Ericsson/codechecker
- https://github.com/pypa/advisory-database/tree/main/vulns/codechecker/PYSEC-2025-12.yaml
CVE-2024-53829 · published · modified · JSON