tocsin

PyPI/apache-airflow CVE-2026-59242: medium 5.4, EPSS 0.53%

Apache Airflow XCom API permits unsafe deserialization through JSON string literals

Action: Upgrade apache-airflow to 3.3.1 or later.

pip install apache-airflow==3.3.1

Affected

introducedfixedlast affected
03.3.1-

Fixed versions

3.3.1

Sources

CVE-2026-59242 · published · modified · JSON