PyPI/guarddog CVE-2026-22870: high 7.5, EPSS 0.51%
GuardDog Zip Bomb Vulnerability in safe_extract() Allows DoS
Action: Upgrade guarddog to 2.7.1 or later.
pip install guarddog==2.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.1 | - |
Fixed versions
| 2.7.1 |
Sources
- osv: GHSA-ffj4-jq7m-9g6v
- nvd: CVE-2026-22870
- https://github.com/DataDog/guarddog/security/advisories/GHSA-ffj4-jq7m-9g6v
- https://github.com/DataDog/guarddog/commit/c3fb07b4838945f42497e78b7a02bcfb1e63969b
- https://github.com/DataDog/guarddog
CVE-2026-22870 · published · modified · JSON