PyPI/webargs CVE-2020-7965: high 8.8, EPSS 0.61%
Cross-Site Request Forgery in Webargs
Action: Upgrade webargs to 5.5.3 or later.
pip install webargs==5.5.3pip install webargs==6.0.0b4Affected
| introduced | fixed | last affected |
|---|---|---|
| 5.0.0 | 5.5.3 | - |
| 6.0.0b1 | 6.0.0b4 | - |
Fixed versions
| 5.5.3 | 6.0.0b4 |
Sources
- osv: GHSA-fjq3-5pxw-4wj4
- https://nvd.nist.gov/vuln/detail/CVE-2020-7965
- https://github.com/marshmallow-code/webargs/commit/b9ee8b0aa668207a363d9fd21d967eeadb975c3e
- https://github.com/marshmallow-code/webargs
- https://github.com/pypa/advisory-database/tree/main/vulns/webargs/PYSEC-2020-156.yaml
- https://webargs.readthedocs.io/en/latest/changelog.html
- https://webargs.readthedocs.io/en/latest/changelog.html#b4-2020-01-28
- https://webargs.readthedocs.io/en/latest/changelog.html#id11
CVE-2020-7965 · published · modified · JSON