PyPI/zope CVE-2021-32811: high 7.5, EPSS 2.30%
Remote Code Execution via Script (Python) objects under Python 3
Action: Upgrade zope to 4.6.3 or later.
pip install zope==4.6.3pip install zope==5.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.0 | 4.6.3 | - |
| 5.0 | 5.3 | - |
Fixed versions
| 4.6.3 | 5.3 |
Sources
- osv: GHSA-g4gq-j4p2-j8fr
- https://github.com/zopefoundation/AccessControl/security/advisories/GHSA-qcx9-j53g-ccgf
- https://github.com/zopefoundation/Zope/security/advisories/GHSA-g4gq-j4p2-j8fr
- https://nvd.nist.gov/vuln/detail/CVE-2021-32811
- https://github.com/zopefoundation/Zope/commit/869f947e586517566509e0ccdd4d99b60704cc02
- https://github.com/zopefoundation/Zope/commit/f72a18dda8e9bf2aedb46168761668464a4be988
- https://github.com/pypa/advisory-database/tree/main/vulns/zope/PYSEC-2021-368.yaml
- https://github.com/zopefoundation/Zope
CVE-2021-32811 · published · modified · JSON