PyPI/exiv2 CVE-2024-24826: medium 5.5, EPSS 0.24%
Exiv2 has an out-of-bounds read in QuickTimeVideo::NikonTagsDecoder
Action: Upgrade exiv2 to 0.16.1 or later.
pip install exiv2==0.16.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.16.0 | 0.16.1 | - |
Fixed versions
| 0.16.1 |
Sources
- osv: GHSA-g9xm-7538-mq8w
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-g9xm-7538-mq8w
- https://nvd.nist.gov/vuln/detail/CVE-2024-24826
- https://github.com/Exiv2/exiv2/pull/2337
- https://github.com/Exiv2/exiv2
- https://github.com/pypa/advisory-database/tree/main/vulns/exiv2/PYSEC-2024-106.yaml
CVE-2024-24826 · published · modified · JSON