PyPI/mitmproxy CVE-2022-24766: critical 9.8, EPSS 1.63%
Insufficient Protection against HTTP Request Smuggling in mitmproxy
Action: Upgrade mitmproxy to 8.0.0 or later.
pip install mitmproxy==8.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 8.0.0 | - |
Fixed versions
| 8.0.0 |
Sources
- osv: GHSA-gcx2-gvj7-pxv3
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-gcx2-gvj7-pxv3
- https://nvd.nist.gov/vuln/detail/CVE-2022-24766
- https://github.com/mitmproxy/mitmproxy/commit/b06fb6d157087d526bd02e7aadbe37c56865c71b
- https://github.com/mitmproxy/mitmproxy
- https://github.com/pypa/advisory-database/tree/main/vulns/mitmproxy/PYSEC-2022-170.yaml
- https://mitmproxy.org/posts/releases/mitmproxy8
CVE-2022-24766 · published · modified · JSON