PyPI/tensorflow-cpu CVE-2021-37639: high 8.4, EPSS 0.17%
Null pointer dereference and heap OOB read in operations restoring tensors
Action: Upgrade tensorflow-cpu to 2.3.4 or later.
pip install tensorflow-cpu==2.3.4pip install tensorflow-cpu==2.4.3pip install tensorflow-cpu==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
| 2.5.0 | 2.5.1 | - |
Fixed versions
| 2.3.4 | 2.4.3 | 2.5.1 |
Sources
- osv: GHSA-gh6x-4whr-2qv4#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gh6x-4whr-2qv4
- https://nvd.nist.gov/vuln/detail/CVE-2021-37639
- https://github.com/tensorflow/tensorflow/commit/9e82dce6e6bd1f36a57e08fa85af213e2b2f2622
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-552.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-750.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-261.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-37639 · published · modified · JSON