PyPI/tensorflow-cpu CVE-2022-41890: medium 4.8, EPSS 0.49%
`CHECK` fail in `BCast` overflow
Action: Upgrade tensorflow-cpu to 2.8.4 or later.
pip install tensorflow-cpu==2.8.4pip install tensorflow-cpu==2.9.3pip install tensorflow-cpu==2.10.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.8.4 | - |
| 2.9.0 | 2.9.3 | - |
| 2.10.0 | 2.10.1 | - |
Fixed versions
| 2.8.4 | 2.9.3 | 2.10.1 |
Sources
- osv: GHSA-h246-cgh4-7475#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h246-cgh4-7475
- https://nvd.nist.gov/vuln/detail/CVE-2022-41890
- https://github.com/tensorflow/tensorflow/commit/8310bf8dd188ff780e7fc53245058215a05bdbe5
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/util/bcast.h
CVE-2022-41890 · published · modified · JSON