PyPI/tensorflow CVE-2021-37646: medium 5.5, EPSS 0.15%
Bad alloc in `StringNGrams` caused by integer conversion
Action: Upgrade tensorflow to 2.3.4 or later.
pip install tensorflow==2.3.4pip install tensorflow==2.4.3pip install tensorflow==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
| 2.5.0 | 2.5.1 | - |
Fixed versions
| 2.3.4 | 2.4.3 | 2.5.1 |
Sources
- osv: GHSA-h6jh-7gv5-28vg
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h6jh-7gv5-28vg
- https://nvd.nist.gov/vuln/detail/CVE-2021-37646
- https://github.com/tensorflow/tensorflow/commit/c283e542a3f422420cfdb332414543b62fc4e4a5
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-559.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-757.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-268.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-37646 · published · modified · JSON