PyPI/dagster CVE-2025-51481: medium 6.6, EPSS 0.62%
Dagster Local File Inclusion vulnerability
Action: Upgrade dagster to 1.10.16 or later.
pip install dagster==1.10.16Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.10.16 | - |
Fixed versions
| 1.10.16 |
Sources
- osv: GHSA-h7x8-jv97-fvvm
- https://nvd.nist.gov/vuln/detail/CVE-2025-51481
- https://github.com/dagster-io/dagster/pull/30002
- https://github.com/dagster-io/dagster/commit/3a3cec2b51577c4970e6fc4c199cda6418c09a9d
- https://github.com/dagster-io/dagster
- https://github.com/pypa/advisory-database/tree/main/vulns/dagster-ge/PYSEC-2025-102.yaml
- https://www.gecko.security/blog/cve-2025-51481
CVE-2025-51481 · published · modified · JSON