PyPI/tensorflow-gpu CVE-2021-37651: high 7.1, EPSS 0.17%
Heap buffer overflow in `FractionalAvgPoolGrad`
Action: Upgrade tensorflow-gpu to 2.3.4 or later.
pip install tensorflow-gpu==2.3.4pip install tensorflow-gpu==2.4.3pip install tensorflow-gpu==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
| 2.5.0 | 2.5.1 | - |
Fixed versions
| 2.3.4 | 2.4.3 | 2.5.1 |
Sources
- osv: GHSA-hpv4-7p9c-mvfr#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-hpv4-7p9c-mvfr
- https://nvd.nist.gov/vuln/detail/CVE-2021-37651
- https://github.com/tensorflow/tensorflow/commit/0f931751fb20f565c4e94aa6df58d54a003cdb30
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-564.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-762.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-273.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-37651 · published · modified · JSON