PyPI/mercurial CVE-2017-1000115: high 7.5, EPSS 4.81%
Mercurial missing symlink check
Action: Upgrade mercurial to 4.3.1 or later.
pip install mercurial==4.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.3.1 | - |
Fixed versions
| 4.3.1 |
Sources
- osv: GHSA-hvr9-wr9p-grgr
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000115
- https://access.redhat.com/errata/RHSA-2017:2489
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2017-88.yaml
- https://security.gentoo.org/glsa/201709-18
- https://web.archive.org/web/20200227155758/http://www.securityfocus.com/bid/100290
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.3_.2F_4.3.1_.282017-08-10.29
- http://www.debian.org/security/2017/dsa-3963
CVE-2017-1000115 · published · modified · JSON