PyPI/tensorflow-gpu CVE-2021-37638: high 7.7, EPSS 0.17%
Null pointer dereference in `RaggedTensorToTensor`
Action: Upgrade tensorflow-gpu to 2.3.4 or later.
pip install tensorflow-gpu==2.3.4pip install tensorflow-gpu==2.4.3pip install tensorflow-gpu==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
| 2.5.0 | 2.5.1 | - |
Fixed versions
| 2.3.4 | 2.4.3 | 2.5.1 |
Sources
- osv: GHSA-hwr7-8gxx-fj5p#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-hwr7-8gxx-fj5p
- https://nvd.nist.gov/vuln/detail/CVE-2021-37638
- https://github.com/tensorflow/tensorflow/commit/301ae88b331d37a2a16159b65b255f4f9eb39314
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-551.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-749.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-260.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-37638 · published · modified · JSON