PyPI/octoprint CVE-2026-54134: high 7, EPSS 0.32%
OctoPrint has possible file exfiltration via query parameters on upload endpoints
Action: Upgrade octoprint to 1.11.8 or later.
pip install octoprint==1.11.8pip install octoprint==2.0.0rc3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.11.8 | - |
| 2.0.0rc1 | 2.0.0rc3 | - |
Fixed versions
| 1.11.8 | 2.0.0rc3 |
Sources
- osv: GHSA-j4h9-pm27-4rfw
- nvd: CVE-2026-54134
- https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-j4h9-pm27-4rfw
- https://github.com/OctoPrint/OctoPrint
- https://github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2026-2687.yaml
CVE-2026-54134 · published · modified · JSON