PyPI/aiohttp CVE-2026-34993: medium 6.4, EPSS 0.18%
AIOHTTP is Vulnerable to Deserialization of Untrusted Data
Action: Upgrade aiohttp to 3.14.0 or later.
pip install aiohttp==3.14.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.14.0 | - |
Fixed versions
| 3.14.0 |
Sources
- osv: GHSA-jg22-mg44-37j8
- https://github.com/aio-libs/aiohttp/security/advisories/GHSA-jg22-mg44-37j8
- https://nvd.nist.gov/vuln/detail/CVE-2026-34993
- https://github.com/aio-libs/aiohttp/commit/dcf40f30637e8752c76781cf6703b5a236749a00
- https://github.com/aio-libs/aiohttp
CVE-2026-34993 · published · modified · JSON