PyPI/pypdf CVE-2026-102997: high 7.5, EPSS 0.34%
pypdf: Possible long runtimes for partially malformed FlateDecode streams (Follow-up)
Action: Upgrade pypdf to 6.18.1 or later.
pip install pypdf==6.18.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.18.1 | - |
Fixed versions
| 6.18.1 |
Sources
- osv: GHSA-jw7q-gvrg-4vj3
- nvd: CVE-2026-102997
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-jw7q-gvrg-4vj3
- https://github.com/py-pdf/pypdf/pull/4073
- https://github.com/py-pdf/pypdf/commit/d9d38cf99b115deb562d3b68f36c33027bc04f79
- https://github.com/py-pdf/pypdf
- https://github.com/py-pdf/pypdf/releases/tag/6.18.1
CVE-2026-102997 · published · modified · JSON