PyPI/cobbler CVE-2024-47533: critical 9.8, EPSS 4.00%
cobbler allows anyone to connect to cobbler XML-RPC server with known password and make changes
Action: Upgrade cobbler to 3.2.3 or later.
pip install cobbler==3.3.7pip install cobbler==3.2.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.3.0 | 3.3.7 | - |
| 3.0.0 | 3.2.3 | - |
Fixed versions
| 3.3.7 | 3.2.3 |
Sources
- osv: GHSA-m26c-fcgh-cp6h
- https://github.com/cobbler/cobbler/security/advisories/GHSA-m26c-fcgh-cp6h
- https://nvd.nist.gov/vuln/detail/CVE-2024-47533
- https://github.com/cobbler/cobbler/commit/32c5cada013dc8daa7320a8eda9932c2814742b0
- https://github.com/cobbler/cobbler/commit/e19717623c10b29e7466ed4ab23515a94beb2dda
- https://github.com/cobbler/cobbler
CVE-2024-47533 · published · modified · JSON