PyPI/picklescan CVE-2025-71321: critical 9.8, EPSS 0.82%
Picklescan vulnerable to Arbitrary File Writing
Action: Upgrade picklescan to 0.0.33 or later.
pip install picklescan==0.0.33Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.33 | - |
Fixed versions
| 0.0.33 |
Sources
- osv: GHSA-m273-6v24-x4m4
- nvd: CVE-2025-71321
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-m273-6v24-x4m4
- https://github.com/mmaitre314/picklescan/pull/53
- https://github.com/mmaitre314/picklescan/commit/70c1c6c31beb6baaf52c8db1b6c3c0e84a6f9dab
- https://github.com/mmaitre314/picklescan
- https://github.com/mmaitre314/picklescan/releases/tag/v0.0.33
- https://www.vulncheck.com/advisories/picklescan-arbitrary-file-writing-via-distutils-module-bypass
CVE-2025-71321 · published · modified · JSON