PyPI/tensorflow-gpu CVE-2022-36018: medium 5.9, EPSS 0.46%
TensorFlow vulnerable to `CHECK` fail in `RaggedTensorToVariant`
Action: Upgrade tensorflow-gpu to 2.7.2 or later.
pip install tensorflow-gpu==2.7.2pip install tensorflow-gpu==2.8.1pip install tensorflow-gpu==2.9.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.2 | - |
| 2.8.0 | 2.8.1 | - |
| 2.9.0 | 2.9.1 | - |
Fixed versions
| 2.7.2 | 2.8.1 | 2.9.1 |
Sources
- osv: GHSA-m6cv-4fmf-66xf#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-m6cv-4fmf-66xf
- https://nvd.nist.gov/vuln/detail/CVE-2022-36018
- https://github.com/tensorflow/tensorflow/commit/88f93dfe691563baa4ae1e80ccde2d5c7a143821
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0
CVE-2022-36018 · published · modified · JSON