PyPI/llama-index-core CVE-2025-3108: medium 5, EPSS 0.50%
LlamaIndex has Incomplete Documentation of Program Execution related to JsonPickleSerializer component
Action: Upgrade llama-index-core to 0.12.41 or later.
pip install llama-index-core==0.12.41Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.11.15 | 0.12.41 | - |
Fixed versions
| 0.12.41 |
Sources
- osv: GHSA-m84c-4c34-28gf
- https://nvd.nist.gov/vuln/detail/CVE-2025-3108
- https://github.com/run-llama/llama_index/commit/702e4340623092fac4cf2fe95eb9465034856da3
- https://github.com/run-llama/llama_index
- https://github.com/run-llama/llama_index/blob/v0.12.41/CHANGELOG.md#llama-index-core-01241
- https://huntr.com/bounties/9b55a5e8-74e6-4241-b323-e360dc8b110a
CVE-2025-3108 · published · modified · JSON