PyPI/compliance-trestle CVE-2026-45774: medium 6.9, EPSS 0.54%
compliance-trestle Profile Import has an Arbitrary File Read via trestle:// URI and Relative Path Traversal
Action: Upgrade compliance-trestle to 3.12.2 or later.
pip install compliance-trestle==4.0.3pip install compliance-trestle==3.12.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.0.0 | 4.0.3 | - |
| 0 | 3.12.2 | - |
Fixed versions
| 4.0.3 | 3.12.2 |
Sources
- osv: GHSA-mj4x-vf5c-5xg8
- nvd: CVE-2026-45774
- https://github.com/oscal-compass/compliance-trestle/security/advisories/GHSA-mj4x-vf5c-5xg8
- https://github.com/oscal-compass/compliance-trestle/commit/5c65c5926fe7ca908b9c1d281f904e7d97ba8310
- https://github.com/oscal-compass/compliance-trestle/commit/d00a0c2f702c24f7016009fbd626036f5c46f47b
- https://github.com/oscal-compass/compliance-trestle
CVE-2026-45774 · published · modified · JSON