PyPI/tensorflow-gpu CVE-2021-29610: low 3.6, EPSS 0.20%
Invalid validation in `QuantizeAndDequantizeV2`
Action: Upgrade tensorflow-gpu to 2.1.4 or later.
pip install tensorflow-gpu==2.1.4pip install tensorflow-gpu==2.2.3pip install tensorflow-gpu==2.3.3pip install tensorflow-gpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: GHSA-mq5c-prh3-3f3h#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mq5c-prh3-3f3h
- https://nvd.nist.gov/vuln/detail/CVE-2021-29610
- https://github.com/tensorflow/tensorflow/commit/c5b0d5f8ac19888e46ca14b0e27562e7fbbee9a9
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-538.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-736.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-247.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-29610 · published · modified · JSON