PyPI/tensorflow CVE-2021-29585: low 2.5, EPSS 0.20%
Division by zero in padding computation in TFLite
Action: Upgrade tensorflow to 2.1.4 or later.
pip install tensorflow==2.1.4pip install tensorflow==2.2.3pip install tensorflow==2.3.3pip install tensorflow==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: GHSA-mv78-g7wq-mhp4
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mv78-g7wq-mhp4
- https://nvd.nist.gov/vuln/detail/CVE-2021-29585
- https://github.com/tensorflow/tensorflow/commit/49847ae69a4e1a97ae7f2db5e217c77721e37948
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-513.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-711.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-222.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/0c9692ae7b1671c983569e5d3de5565843d500cf/tensorflow/lite/kernels/padding.h#L43-L55
CVE-2021-29585 · published · modified · JSON