PyPI/tensorflow CVE-2018-7575: critical 9.8, EPSS 0.61%
Integer Overflow or Wraparound in Google TensorFlow
Action: Upgrade tensorflow to 1.7.1 or later.
pip install tensorflow==1.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.0.0 | 1.7.1 | - |
Fixed versions
| 1.7.1 |
Sources
- osv: GHSA-mw6v-crh8-8533
- https://nvd.nist.gov/vuln/detail/CVE-2018-7575
- https://github.com/tensorflow/tensorflow/commit/d107fee1e4a9a4462f01564798d345802acc2aef
- https://github.com/advisories/GHSA-mw6v-crh8-8533
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-223.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-230.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-205.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-004.md
CVE-2018-7575 · published · modified · JSON