PyPI/django CVE-2009-3695: high 7.5, EPSS 3.72%
Django Regex Algorithmic Complexity Causes Denial of Service
Action: Upgrade django to 1.0.4 or later.
pip install django==1.0.4pip install django==1.1.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.0 | 1.0.4 | - |
| 1.1 | 1.1.1 | - |
Fixed versions
| 1.0.4 | 1.1.1 |
Sources
- osv: GHSA-p6m5-h7pp-v2x5
- https://nvd.nist.gov/vuln/detail/CVE-2009-3695
- https://github.com/django/django/commit/594a28a9044120bed58671dde8a805c9e0f6c79a
- https://github.com/django/django/commit/e3e992e18b368fcd56aabafc1b5bf80a6e11b495
- https://exchange.xforce.ibmcloud.com/vulnerabilities/53727
- https://github.com/django/django
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2009-4.yaml
- https://web.archive.org/web/20091013093057/http://secunia.com/advisories/36968
- https://web.archive.org/web/20091017070244/http://secunia.com/advisories/36948
- https://web.archive.org/web/20200228171918/http://www.securityfocus.com/bid/36655
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=550457
- http://groups.google.com/group/django-users/browse_thread/thread/15df9e45118dfc51
- http://www.debian.org/security/2009/dsa-1905
- http://www.djangoproject.com/weblog/2009/oct/09/security
- http://www.openwall.com/lists/oss-security/2009/10/13/6
CVE-2009-3695 · published · modified · JSON