PyPI/tensorflow-cpu CVE-2021-29563: low 2.5, EPSS 0.19%
CHECK-fail in `tf.raw_ops.RFFT`
Action: Upgrade tensorflow-cpu to 2.1.4 or later.
pip install tensorflow-cpu==2.1.4pip install tensorflow-cpu==2.2.3pip install tensorflow-cpu==2.3.3pip install tensorflow-cpu==2.4.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.4 | - |
| 2.2.0 | 2.2.3 | - |
| 2.3.0 | 2.3.3 | - |
| 2.4.0 | 2.4.2 | - |
Fixed versions
| 2.1.4 | 2.2.3 | 2.3.3 | 2.4.2 |
Sources
- osv: GHSA-ph87-fvjr-v33w#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-ph87-fvjr-v33w
- https://nvd.nist.gov/vuln/detail/CVE-2021-29563
- https://github.com/tensorflow/tensorflow/commit/31bd5026304677faa8a0b77602c6154171b9aec1
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-491.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-689.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-200.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-29563 · published · modified · JSON