PyPI/vyper CVE-2023-32059: high 7.5, EPSS 0.73%
Vyper vulnerable to incorrect ordering of arguments for kwargs passed to internal calls
Action: Upgrade vyper to 0.3.8 or later.
pip install vyper==0.3.8Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.3.8 | - |
Fixed versions
| 0.3.8 |
Sources
- osv: GHSA-ph9x-4vc9-m39g
- https://github.com/vyperlang/vyper/security/advisories/GHSA-ph9x-4vc9-m39g
- https://nvd.nist.gov/vuln/detail/CVE-2023-32059
- https://github.com/vyperlang/vyper/commit/c3e68c302aa6e1429946473769dd1232145822ac
- https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2023-79.yaml
- https://github.com/vyperlang/vyper
CVE-2023-32059 · published · modified · JSON