PyPI/apache-airflow CVE-2026-22922: medium 6.5, EPSS 0.45%
Apache Airflow Has an Authorization Bypass That Allows Unauthorized Task Log Access
Action: Upgrade apache-airflow to 3.1.7 or later.
pip install apache-airflow==3.1.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.1.0 | 3.1.7 | - |
Fixed versions
| 3.1.7 |
Sources
- osv: GHSA-pm44-x5x7-24c4
- https://nvd.nist.gov/vuln/detail/CVE-2026-22922
- https://github.com/apache/airflow/pull/60412
- https://github.com/apache/airflow
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2026-11.yaml
- https://lists.apache.org/thread/gdb7vffhpmrj5hp1j0oj1j13o4vmsq40
- http://www.openwall.com/lists/oss-security/2026/02/09/2
CVE-2026-22922 · published · modified · JSON