tocsin

PyPI/vyper CVE-2024-32481: medium 5.3, EPSS 0.80%

vyper's range(start, start + N) reverts for negative numbers

Action: Upgrade vyper to 0.4.0 or later.

pip install vyper==0.4.0

Affected

introducedfixedlast affected
0.3.80.4.0-

Fixed versions

0.4.0

Sources

CVE-2024-32481 · published · modified · JSON