PyPI/nicegui CVE-2026-45554: medium 5.3, EPSS 0.34%
NiceGUI: Unauthenticated log-volume denial of service in dynamic resource routes
Action: Upgrade nicegui to 3.12.0 or later.
pip install nicegui==3.12.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.12.0 | - |
Fixed versions
| 3.12.0 |
Sources
- osv: GHSA-pq7c-x8g4-rvp6
- https://github.com/zauberzeug/nicegui/security/advisories/GHSA-pq7c-x8g4-rvp6
- https://nvd.nist.gov/vuln/detail/CVE-2026-45554
- https://github.com/zauberzeug/nicegui
- https://github.com/zauberzeug/nicegui/releases/tag/v3.12.0
CVE-2026-45554 · published · modified · JSON