PyPI/tensorflow-cpu CVE-2021-41197: medium 5.5, EPSS 0.32%
Crashes due to overflow and `CHECK`-fail in ops with large tensor shapes
Action: Upgrade tensorflow-cpu to 2.4.4 or later.
pip install tensorflow-cpu==2.6.1pip install tensorflow-cpu==2.5.2pip install tensorflow-cpu==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.1 | - |
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
Fixed versions
| 2.6.1 | 2.5.2 | 2.4.4 |
Sources
- osv: GHSA-prcg-wp5q-rv7p#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-prcg-wp5q-rv7p
- https://nvd.nist.gov/vuln/detail/CVE-2021-41197
- https://github.com/tensorflow/tensorflow/issues/46890
- https://github.com/tensorflow/tensorflow/issues/51908
- https://github.com/tensorflow/tensorflow/commit/7c1692bd417eb4f9b33ead749a41166d6080af85
- https://github.com/tensorflow/tensorflow/commit/a871989d7b6c18cdebf2fb4f0e5c5b62fbc19edf
- https://github.com/tensorflow/tensorflow/commit/d81b1351da3e8c884ff836b64458d94e4a157c15
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-607.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-805.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-390.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-41197 · published · modified · JSON