PyPI/spotipy CVE-2025-27154: critical 9.8, EPSS 0.61%
Spotipy's cache file, containing spotify auth token, is created with overly broad permissions
Action: Upgrade spotipy to 2.25.1 or later.
pip install spotipy==2.25.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.25.1 | - |
Fixed versions
| 2.25.1 |
Sources
- osv: GHSA-pwhh-q4h6-w599
- nvd: CVE-2025-27154
- https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-pwhh-q4h6-w599
- https://github.com/spotipy-dev/spotipy/commit/1ca453f6ef87a2a9e9876f52b6cb38d13532ccf2
- https://github.com/spotipy-dev/spotipy
- https://github.com/spotipy-dev/spotipy/blob/master/spotipy/cache_handler.py#L93-L98
- https://github.com/spotipy-dev/spotipy/releases/tag/2.25.1
CVE-2025-27154 · published · modified · JSON